Uploaded image for project: 'Erlang/OTP'
  1. Erlang/OTP
  2. ERL-850

logger_std_h stop logging to file after editing

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 21.2
    • Fix Version/s: 21.3
    • Component/s: kernel
    • Labels:
      None

      Description

      Configure logger_std_h to log to a file.

      When the file is removed it is recreated and no logs are lost, which is good.

      Edit the file (e.g. in vim and save), no future logs are written to the file. Is this intended behaviour?

        Activity

        siri Siri Hansen added a comment -

        No, this is not the intended behavior. Unfortunately, future logs might in this case be written to a backup file created by the editor.

        Thanks for reporting! A correction for this will be included in OTP-21.3

        sdl.web@gmail.com Leo Liu added a comment -

        Thanks. Look forward to 21.3. What should happen to logger_disk_log_h in this case when file gets edited?


          People

          • Assignee:
            siri Siri Hansen
            Reporter:
            sdl.web@gmail.com Leo Liu
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development