Uploaded image for project: 'Erlang/OTP'
  1. Erlang/OTP
  2. ERL-1270

Common Test -step option oddities

    XMLWordPrintable

    Details

    • Type: Question
    • Status: Help Wanted
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 23.0
    • Fix Version/s: None
    • Component/s: common_test
    • Labels:
      None

      Description

      Hello, we have been trying to make the -step option work when used via ct_run via Erlang.mk. The option seems to enable things, because we do get a debugger window open if we set a breakpoint manually inside the test case (using, for example, i:ib(?MODULE, ?LINE + 1)).

      From our understanding the -step option should automatically add breakpoints to the beginning of all test case functions.

      Using "-step config" properly enables breakpoints on the init_* and end_* functions. But still nothing on the test cases.

      I've been trying against this test suite personally: https://github.com/ninenines/cowboy/blob/master/test/rfc7230_SUITE.erl

      I've added -step to the CT_OPTS line in the Makefile and ran "make ct-rfc7230 t=http:accept_at_least_1_empty_line".

        Attachments

          Activity

            People

            Assignee:
            otp_team_ps Team PS
            Reporter:
            essen essen
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: